Suoritettu

Fix compatibility issue (parsing XML data) when upgrading from PHP 7.0 to 7.4

The code I have was provided to me some years back and works perfectly up to version 7.0

When I upgrade the server it throws approx 6 errors all similar to the example provided:

"Fatal error: Uncaught Error: Cannot use string offset as an array in /var/www/xxxxxx/[login to view URL](258) : eval()'d code:1 Stack trace: #0"

Can you solve the following Typical error?

I want to upgrade a server to PHP 7.4 but the above typical error appears when moving from version 7.0 to 7.1 onwards. Approx 6 errors exist similar to above and it happens when parsing data in an XML file. I want all errors fixed however I believe that it's the same issue that is causing them.

Are you familiar with upgrading php and issues with the eval() function?

Taidot: PHP, XML, Tietojärjestelmäarkkitehtuuri, WordPress, Verkkosivujen testaus, Web hosting, Verkkopalvelut, Verkkosivun hallinta, Website Optimization

Tietoa asiakkaasta:
( 0 arvostelua ) Carrick on Shannon, Ireland

Projektin tunnus: #34327562

Myönnetty käyttäjälle:

(41 Arvostelua)
5.8

34 freelanceria on tarjonnut keskimäärin €218 tähän työhön

(1271 arvostelua)
9.4
(367 arvostelua)
8.9
(353 arvostelua)
8.8
(138 arvostelua)
8.8
(313 arvostelua)
8.0
(584 arvostelua)
8.2
(113 arvostelua)
8.0
Friends4it

We already have built large scale applications, CRMs, ERPs and huge systems can be found at our website. Like [login to view URL] [login to view URL] [login to view URL] [login to view URL] [login to view URL] https: Lisää

€220 EUR 6 päivässä
(452 arvostelua)
8.2
(1220 arvostelua)
7.7
(137 arvostelua)
7.7
(122 arvostelua)
7.4
(481 arvostelua)
7.3
(224 arvostelua)
7.2
(102 arvostelua)
7.3
(206 arvostelua)
7.0
(251 arvostelua)
7.2
(261 arvostelua)
7.1
(201 arvostelua)
6.6
(176 arvostelua)
6.9
c0909h1179

Hi there, I'm the best here! Would love to work together. Thanks!

€150 EUR 1 päivässä
(31 arvostelua)
6.3